欢迎光临
我们一直在努力

k线形态 选股公式(K线形态选股公式汇总)

k线形态 选股公式

对于K线形态,小编之前做过总结,有三十多种,但是对于这么多的K线形态,投资者不可能一个一个来看,毕竟有将近3000多个股,且每个个股也有自己的多个时态图,那么,如何从众多个股中选到自己想要的k线形态的股票,今天,小编简单给大家讲讲。

前段时间有朋友留言,说利用公式炒股是幼稚园的水平,我觉得利用公式只是减少选股票的时间,最终买入还是要靠我自己进行判断。闲话少说,直接上干货了:

1、红三兵:三根阳线,依次上升。每天的收盘价高于前一天收盘价。

红三兵

A:=L/HHV(H,10)<0.88;B:=EVERY(C>O,3)=1 AND REF(C,3)

XG:COUNT(A,3) AND B AND L>MA(C,5) AND O>MA(C,5);

2、多方炮:多数出现在下跌行情之后,呈现两阳夹一阴形态。

多方炮

V0:=ABS(CLOSE-OPEN)/(HIGH-LOW)>0.5;{多方炮}

V0 AND REF(V0,2) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)OPEN AND CLOSE>REF(CLOSE,2) AND CLOSE>REF(OPEN,1) AND REF(C,1)

{上涨K线模式:两阳夹一阴.判研要领:多方强势,短期看涨。};

叠叠多方炮:

叠叠多方炮

k线形态 选股公式

V1:=CLOSE>OPEN AND REF(CLOSE,1)REF(OPEN,2) AND CLOSE>REF(OPEN,1) AND CLOSE>REF(CLOSE,2);

V2:=V1 AND REF(V1,2) AND C>REF(C,4);

V3:=V1 AND REF(V1,3) AND C>REF(C,5);

V4:=V1 AND REF(V1,4) AND C>REF(C,6);

V2 OR V3 OR V4;

3、出水芙蓉:一根长阳突破短期均线系统,一阳穿三线,必须要有较大成交量配合

出水芙蓉

k线形态 选股公式

MA200:=EMA(CLOSE,20);

MA400:=EMA(CLOSE,40);

MA600:=EMA(C,60);

AA:=BARSLAST(MA400>MA600 AND (MA200=MA400 OR MA200>MA400));

BB:=REF(COUNT(C

CC:=CROSS(C,MA600) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;

芙蓉出水:BB AND CC;

4、双针探底:由两根有一定间隔的带上下影线的K线所组成。两条长下影表示价格经过两次探底,下方有较强的支撑。

k线形态 选股公式

双针探底

A1:=(REF(MIN(CLOSE,OPEN),11)-REF(LOW,11))/(REF(HIGH,11)-REF(LOW,11))>0.5&&

(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.5&&

ABS(REF(LOW,11)-LOW)/REF(LOW,11)<0.002&&REF(LOW,11)=LLV(LOW,15);

A2:=(REF(MIN(CLOSE,OPEN),10)-REF(LOW,10))/(REF(HIGH,10)-REF(LOW,10))>0.5&&

(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.5&&

ABS(REF(LOW,10)-LOW)/REF(LOW,10)<0.002&&REF(LOW,10)=LLV(LOW,15);

A3:=(REF(MIN(CLOSE,OPEN),9)-REF(LOW,9))/(REF(HIGH,9)-REF(LOW,9))>0.5&&

(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.5&&

ABS(REF(LOW,9)-LOW)/REF(LOW,9)<0.002&&REF(LOW,9)=LLV(LOW,15);

A4:=(REF(MIN(CLOSE,OPEN),8)-REF(LOW,8))/(REF(HIGH,8)-REF(LOW,8))>0.5&&

(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.5&&

ABS(REF(LOW,8)-LOW)/REF(LOW,8)<0.002&&REF(LOW,8)=LLV(LOW,13);

A5:=(REF(MIN(CLOSE,OPEN),7)-REF(LOW,7))/(REF(HIGH,7)-REF(LOW,7))>0.5&&

(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.5&&

ABS(REF(LOW,7)-LOW)/REF(LOW,7)<0.002&&REF(LOW,7)=LLV(LOW,10);

A6:=(REF(MIN(CLOSE,OPEN),6)-REF(LOW,6))/(REF(HIGH,6)-REF(LOW,6))>0.5&&

(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.5&&

ABS(REF(LOW,6)-LOW)/REF(LOW,6)<0.002&&REF(LOW,6)=LLV(LOW,10);

A7:=(REF(MIN(CLOSE,OPEN),5)-REF(LOW,5))/(REF(HIGH,5)-REF(LOW,5))>0.5&&

(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.5&&

ABS(REF(LOW,5)-LOW)/REF(LOW,5)<0.002&&REF(LOW,5)=LLV(LOW,10);

A8:=(REF(MIN(CLOSE,OPEN),4)-REF(LOW,4))/(REF(HIGH,4)-REF(LOW,4))>0.5&&

(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.5&&

ABS(REF(LOW,4)-LOW)/REF(LOW,4)<0.002&&REF(LOW,4)=LLV(LOW,6);

A9:=(REF(MIN(CLOSE,OPEN),3)-REF(LOW,3))/(REF(HIGH,3)-REF(LOW,3))>0.5&&

(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.5&&

ABS(REF(LOW,3)-LOW)/REF(LOW,3)<0.002&&REF(LOW,3)=LLV(LOW,6);

A10:=(REF(MIN(CLOSE,OPEN),2)-REF(LOW,2))/(REF(HIGH,2)-REF(LOW,2))>0.5&&

(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.5&&

ABS(REF(LOW,2)-LOW)/REF(LOW,2)<0.002&&REF(LOW,2)=LLV(LOW,6);

A11:=(REF(MIN(CLOSE,OPEN),1)-REF(LOW,1))/(REF(HIGH,1)-REF(LOW,1))>0.5&&

(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.5&&

ABS(REF(LOW,1)-LOW)/REF(LOW,1)<0.002&&REF(LOW,1)=LLV(LOW,4);

A13:A1==A2==A3==A4==A5==A6==A7=A8==A9==A10==A11;

5、缺口:向上跳空缺口,三天不回补则是强势股的表现。

缺口

k线形态 选股公式

XSTK:=LOW>REF(HIGH,1);

TT1:=BARSLAST(XSTK)+1;

HH:=REF(HIGH,TT1);

不回补:=TT1<=3 AND COUNT(XSTK,TT1)>=1 AND LOW>HH AND LOW<=HH*1.01 AND NOT(EXIST(CROSS(HH,LOW),TT1));

COUNT(LOW>REF(HIGH,1),3)>0 AND 不回补;

6、单阳不破:一根大阳线出现之后,其后6——7根K线横向盘整,且所有低价都没有击穿该阳线最低价

k线形态 选股公式

单阳不破最强形态

阳涨幅:=4;

阳倍量:=2;

单阳:=C>O*(1+阳涨幅/100) AND VOL>REF(VOL,1)*阳倍量;

高不破价:=REF(C,BARSLAST(单阳));

中不破价:=REF((C+L)/2,BARSLAST(单阳));

低不破价:=REF(L,BARSLAST(单阳));

两天:=LLV(L,BARSLAST(单阳))>低不破价 OR LLV(L,BARSLAST(单阳))=低不破价;

最强:=LLV(L,BARSLAST(单阳)-3)>高不破价 OR LLV(L,BARSLAST(单阳)-2)=高不破价;

最强选股:BARSLAST(单阳)<9 AND 两天 AND 最强;

7、旭日东升:多在在下跌趋势中出现,出现一根中阴线或大阴线,紧接着出现一根高开的中阳线或大阳线,阳线的收盘价高于阴线开盘价。

k线形态 选股公式

旭日东升

VAR1:=(CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100<-23;

VAR2:=SMA(MAX(CLOSE-REF(CLOSE,1),0),3,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),3,1)*100>16;

VAR3:=100*(HHV(HIGH,27)-CLOSE)/(HHV(HIGH,27)-LLV(LOW,27));

VAR1 AND VAR2 AND CROSS(VAR3,79) AND (OPEN>CLOSE OR OPENMA(VOL,23);

8、量价齐升

量价齐升

S1:=IF(CODELIKE(‘300’),0,1);

S2:=IF(NAMELIKE(‘S’),0,1);

S3:=IF(NAMELIKE(‘*’),0,1);

S4:=DYNAINFO(17)>0;

换手:=VOL/CAPITAL*100;

去掉:=S1 AND S2 AND S3 AND S4;

比前一天高:= C>=REF(C,1)*1.01;

倍量:=VOL/REF(VOL,1)>=1.6;

量价齐升:V>REF(V,1) AND C>REF(C,1) AND CAPITAL/1000000<=5.53 AND C>=6.5 AND C<=16.99 AND C/REF(C,1)>=1.010 AND 倍量 AND 比前一天高 AND 换手>2 AND DYNAINFO(17)>=2.0 AND 去掉 AND CLOSE>OPEN;

赞(0) 打赏
未经允许不得转载:云搜财经 » k线形态 选股公式(K线形态选股公式汇总)
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

更专业 更方便

联系我们联系我们

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏