欢迎光临
我们一直在努力

日线副图怎么改成选股公式(主图或副图指标改为选股公式的方法)

大家好,我是股市帅锅。我们已经学习了16篇编写股票指标的教程,虽然大部分粉丝对指标公式和选股公式有了一定的了解,但是对于主图或副图指标改为选股公式的具体方法,还是不太清楚,所以满足部分粉丝的要求,今天我们先插队一篇,学学这个改写的方法。

日线副图怎么改成选股公式

我们以其中一个粉丝发给我的副图指标为例,当然他发给我,我也没有单独回复他,我说过,我不会单独为某个粉丝编指标,我是教大家编指标,而是替大家编指标,这是我的原则。他给我的指标代码是这样的。

———-

{N:0,50,5 M:0,50,5}

H1:=EMA(DCLOSE,5);

A1:=LLV(DCLOSE,5);

A2:=A1+1/CURRBARSCOUNT*N;

A3:=IF(CURRBARSCOUNT<20 AND A1>REF(A1,1),CONST(REF(A2,10)),A1);

A4:=MA(A3,10);

A5:=H1+1/CURRBARSCOUNT*M;

A6:=IF(CURRBARSCOUNT<20 AND A1>REF(A1,1),CONST(REF(A5,10)),A3); A7:MA(A6,10);

L1:=LLV(L,10); DRAWBAND(A4,90,L1,RGB(35,135,35));

DRAWBAND(A7,90,A4,90);

主力操作线:MA(C,24),LINETHICK2,COLORLIMAGENTA;

操作线2:MA(C,26),LINETHICK1,COLORLICYAN; DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

启动点:=(DCLOSE-REF(C,1))/REF(C,1)*100;

XG:=CROSS(启动点,10);

L3:IF(XG,O,L1*0.999),COLORYELLOW;

STICKLINE(XG,L3,L3,100,0);

DRAWTEXT(XG,L3,’买点’),COLORMAGENTA;

———

拿到代码,我们首先看到的是{N:0,50,5 M:0,50,5},我们知道大括号内的内容是不参与指标运算的,但是它告诉我们N的默认参数是5,M的默认参数也是5,我们可以通过参数区分别对N和M进行参数填写,也可以直接把下面代码中的N和M都改为5。

然后,改好之后,我们先把代码复制到软件里看看,究竟是什么指标。

日线副图怎么改成选股公式日线副图怎么改成选股公式

建成指标后,我放到副图上,看到这个指标有色带,有买点提示,同时提示有未来函数,一般情况下,我看到未来函数,我就不会拿它去选股了,但也不是绝对。

既然有买点提示,该指标改为选股指标,肯定是满足某条件时,标注买点两字,那个条件,作为选股条件。标注文字,我们已经学过是用函数DRAWTEXT,所以我们去找代码里含有该函数的语句,我们找到了这一句:

DRAWTEXT(XG,L3,’买点’),COLORMAGENTA;

这句代码里,我们看到了需要满足的条件是XG,我们再去找XG的输出或赋值,我们在代码中找到了这句:

XG:=CROSS(启动点,10);

也就是说选股条件是CROSS(启动点,10),接下来的事情就比较简单了。

1、把这一句后面的所有代码都删除,因为只要用到CROSS(启动点,10),其他后面的用不到了。

2、选股公式中,不允许有一项以上的输出,所以只有:的都在:后面加上=,改为赋值,如果有两项或以上输出,系统会提示错误,并告诉你输出不能超过1项。

3、选股公式中,不能有画线,画图标,画文字等等内容,DARW开头的,STICKLINE开头的内容全部删除,看不懂是不是画线等内容的,可以去动态翻译里看,如果没有删除,系统也会提示错误。

4、把XG:=CROSS(启动点,10); 这一句中的=删除,因为选股公式可以有一项输出,所以这一项把赋值改为输出,赋值不能作为选股条件。

修改后的代码:

———–

H1:=EMA(DCLOSE,5);

A1:=LLV(DCLOSE,5);

A2:=A1+1/CURRBARSCOUNT*5;

A3:=IF(CURRBARSCOUNT<20 AND A1>REF(A1,1),CONST(REF(A2,10)),A1);

A4:=MA(A3,10);

A5:=H1+1/CURRBARSCOUNT*5;

A6:=IF(CURRBARSCOUNT<20 AND A1>REF(A1,1),CONST(REF(A5,10)),A3);

A7:=MA(A6,10); {这句改为赋值,加=}

L1:=LLV(L,10);

{DRAWBAND(A4,90,L1,RGB(35,135,35));}

{DRAWBAND(A7,90,A4,90); 这两句是画色带,删除}

主力操作线:=MA(C,24),LINETHICK2,COLORLIMAGENTA;{这句改为赋值,加=}

操作线2:=MA(C,26),LINETHICK1,COLORLICYAN; {这句改为赋值,加=}

{DRAWKLINE(HIGH,OPEN,LOW,CLOSE);这句画线,删除}

启动点:=(DCLOSE-REF(C,1))/REF(C,1)*100;

XG:CROSS(启动点,10); {这一句里的=删除}

{L3:IF(XG,O,L1*0.999),COLORYELLOW;}

{STICKLINE(XG,L3,L3,100,0); }

{DRAWTEXT(XG,L3,’买点’),COLORMAGENTA;这三句在XG的后面,全部删除};

———

我们来进行测试:

日线副图怎么改成选股公式

把代码复制过去之后,我们发现,顺利通过,但是能不能选出股票还需要测试,我们来试一下:

日线副图怎么改成选股公式

我测试之后,是可以选到股票的,同时也是最近这个交易日上面显示买入字样,说明我们改的选股公式是成功的。

接下来的文字是我要强调的:

1、我没有去研究这个指标公式的实际意义,我并不想去研究别人编写的代码。

2、该指标含有未来函数,究竟是什么未来函数,我也没有精力去细看了,反正这个指标不会作为我的选股公式。

3、我们不管从哪里拿来的选股公式,首先要知道代码描述的含义,如果不知道含义,至少要知道用法,一个没有用法的选股公式,好比没有内功心法的武功秘籍,容易误导。

4、就算知道了含义,也知道了用法,也要进行多次的实际测试,可以用模拟盘来测试效果。

5、不要迷信任何选股公式,包括我写的选股公式在内,因为选股只是交易的第一步,更重要的是后面的卖出动作。

今天的内容就到这里,多多点赞,收藏,转发,评论,多互动,让我看到你也在努力地学,谢谢!

赞(0) 打赏
未经允许不得转载:云搜财经 » 日线副图怎么改成选股公式(主图或副图指标改为选股公式的方法)
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

更专业 更方便

联系我们联系我们

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏