欢迎光临
我们一直在努力

主力行为macd选股公式(不断优化的MACD选股公式)

MACD指标又称指数平滑异同移动平均线,由两条平滑移动均线,一条为快线,称之为DIF,在通常炒股软件中,用白色显示,另一条为慢线,称之为DEA,用黄色显示,以及零轴、零轴之上的红色柱和零轴之下的绿色柱组合而成。

MACD技术图形:

主力行为macd选股公式

下面我们来说一下使用MACD指标所应当遵循的基本原则:

⒈当DIF和DEA处于0轴以上时,属于多头市场。

⒉当DIF和DEA处于0轴以下时,属于空头市场。

⒊柱状线收缩和放大。

⒋牛皮市道中指标将失真。

MACD指标缺点

⒈由于MACD是一项中、长线指标,买进点、卖出点和最低价、最高价之间的价差较大。当行情忽上忽下幅度太小或盘整时,按照信号进场后随即又要出场,买卖之间可能没有利润,也许还要赔点价差或手续费。

⒉一两天内涨跌幅度特别大时,MACD来不及反应,因为MACD的移动相当缓和,比较行情的移动有一定的时间差,所以一旦行情迅速大幅涨跌,MACD不会立即产生信号,此时,MACD无法发生作用。

KDJ是一种指示“超买超卖”的指标,跟MACD不同,这类指标的最大特点是有上下的界限。

KDJ指标,是由K,D,J三根线,以及0-100的数轴线组成的,公式我就不写了,参数一般是(9,3,3),可以修改,数字越大,指标越不敏感。如下面黄金的一张KDJ图:

主力行为macd选股公式

1.按对价格的敏感程度,J线最高,D线次之,最不敏感是K线,意思就是,比如价格上涨,首先会跟随上涨的,是J线,以此类推。

2.KDJ会在0-100内穿行,但是也会出现J线在100以上,0以下的负数值

3.该指标也是价格先,指标后,价格决定指标,其一些固有特点上,会使得指标的状态,运行方式上,能够起到一些预示价格的作用,用法也就随之产生。

4.在MACD,RSI,KDJ等一系列同属性指标里面,KDJ是最敏感的摆动指标,其单独作用力并不好,我建议是和其他的一些技术想结合,效果会更好。

基本用法:

1.看超买超卖

直接看一张黄金的KDJ图

主力行为macd选股公式

80轴以上是超买区域,20轴以下是超卖区域。

超买区域要注意回落,超卖区域要注意反弹风险。

但其实有经验的都知道,超过80轴一直处于超买状态,行情仍然可能一直上涨不回落;低于20轴一直处于超卖状态,行情也仍然可能一直下跌不反弹,这其实就是KDJ的“钝化”,其意义并不算太大,所以我一直强调,KDJ需要和其他技术指标或者其他分析技术联合使用,才可以发挥这个指标的长处。

那么超买超卖的意义究竟在哪里,如果这么不靠谱的话,当然是“提醒”,进入超买区域,尽量就不要追多了,进入超卖区域,是不是就尽量不要追空,现实意义中,这也是非常有参考价值和实际意义的。

2.看交叉

其实跟MACD一样,KDJ也是有金叉死叉的,但是由于指标的敏感度,所以金死叉相对于MACD而言更容易形成,运行速度也快,相对也就可信性降低。

(1)如果要看死叉,尽量是三线交叉的地方,是在80轴以上,会更加好一些,越高自然是越好的;

(2)如果要看金叉,尽量是三线交叉的地方,是在20轴以下,会更加好一些,越低自然是越好的;

(3)不久之后的二次金叉,或者二次死叉也会更加可信一些。

(4)时间级别越高自然效果也是越好的。

随便看个黄金日线图

主力行为macd选股公式

随便一个阶段的KDJ就能告诉你,这个指标的随机性哪怕在日线图级别,仍然是很大的,金死叉的效果也并不是那么好。

这个指标更大的意义,并不在于提示买卖,而是告诉你目前运行的位置,在真正的交易中,这个指标除了同样的几个摆动指标之外,是百搭的,跟其他的比如趋势指标,均线,布林,瀑布线,其他的一些分析方法,比如形态学等,都是非常良好的补充。

要明确学习这个指标的实际意义,在于学习一种补充指标,学习一种信号足够敏感的搭配方案。

今天越声攻略(yslc688)就教大家如何用MACD看穿主力意图。

“MACD看穿主力”口诀:

1、底背离、低位金叉、二次金叉,还有双金叉(低位金叉和二次金叉)、三全项(底背离、低位金叉和二次金叉);

2、增加主力做坐庄四部曲:主力吸筹、主力拉升、主力派送和主力砸盘,主力行为一目了然;

3、把DIF线做成可以变色的线,主升浪时是红色线,主跌浪时是绿色线;

4、柱体也可以做出更多的颜色,零轴以下的不说了,零轴以上的,细分为黄金柱表买入、红柱表持有、绿柱表卖出。

“MACD看穿主力”用法:

1、主力拉升、底背离、低位金叉、二次金叉、双金叉和三全项,可以买入;

2、在0轴以上出红色MACD柱,主力拉升=1,建议持有;

3、在0轴以上出绿色MACD柱,主力拉升=0,坚决卖出。

实战分析:

主力行为macd选股公式主力行为macd选股公式主力行为macd选股公式主力行为macd选股公式主力行为macd选股公式主力行为macd选股公式主力行为macd选股公式主力行为macd选股公式

超强MACD代码:

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

OBV2:=EMA(OBV1,3)-MA(OBV1,9);

OBV3:=EMA(IF(OBV2>0,OBV2,0),3);

MAC3:=MA(C,3);

SHORT:=12;LONG:=26;MID:=9;

DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORYELLOW ;

DEA:EMA(DIF,MID)COLORFF9900 ;

MACD:=(DIF-DEA)*2;

STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,2,0),COLORYELLOW;

吸:=XLPL.NOTEXT吸;

拉:=XLPL.NOTEXT拉;

派:=XLPL.NOTEXT派;

落:=XLPL.NOTEXT落;

STICKLINE(吸,0,MACD,1,0),COLORLIRED;

STICKLINE(拉,0,MACD,1,0),COLORRED;

STICKLINE(派,0,MACD,1,0),COLORGREEN;

STICKLINE(落,0,MACD,1,0),COLORWHITE;

入1:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;

入2:IF(DIF

低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;

STICKLINE(低位金叉,0,0.08,6,0),COLORFF00FF;

DRAWTEXT(低位金叉,0.16,’ 低位金叉’),COLORWHITE;

JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,0.06,6,0),COLORFFCC00;

DRAWICON(二次金叉,DEA*0.9,1) ;

DRAWTEXT(二次金叉,0.2,’ 二次金叉’),COLORYELLOW;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

DRAWTEXT(底背离,0.12,’ 底背离’),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

顶背离:=REF(CLOSE,A2+1)DIF AND CROSS(DEA,DIF);

DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,’三全项’),COLOR0000FF,LINETHICK2;DRAWTEXT_FIX(C>O,0.01,0.9,0,’ WWW.CXH99.COM ‘),COLORRED;

DRAWTEXT_FIX(C>O,1,1,0,’程序化交易模型’),COLORRED;

DRAWTEXT_FIX(C>O,0.01,0.9,0,’ WWW.CXH99.COM ‘),COLORRED;

DRAWTEXT_FIX(C>O,1,1,0,’程序化交易模型’),COLORRED;

以上就是越声攻略(yslc688)给大家分享的“MACD看穿主力”的知识点,希望对大家有所帮助,最后再给大家说明一下运用MACD的时候需要注意的其它事项。

运用MACD指标能研判中长期走势,较易判断上涨或下跌行情的开始和技术、能判断出目前属于多头市场还是空头市场,避免逆向操作、根据指标采取相应的交易策略,降低无谓的频繁进出。

但是,MACD指标也存在它的不足。其不足之处在于当股价在短时间内上下波动较大时,由于MACD指标的反映相对迟缓,不能迅速产生交易信号,并不适用于短线操作。当股价波动幅度较小时,MACD指标发出的交易信号也不明显,不利于分析价格变动较少的个股。

(以上内容仅供参考,不构成操作建议。如自行操作,注意仓位控制和风险自负。)

声明:本内容由越声攻略提供,不代表投资快报认可其投资观点。

赞(0) 打赏
未经允许不得转载:云搜财经 » 主力行为macd选股公式(不断优化的MACD选股公式)
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

更专业 更方便

联系我们联系我们

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏