欢迎光临
我们一直在努力

macd五大金叉选股公式(MACD和MACD金叉的公式大全)

MACD是个很经黄的指标。同时也有很多用法。我搜集了相关的源码,供大家参考 ,喜欢就点个关注。今后为你提供更多的分享。

公式源码,默认是使用在通达信中,但是其他的软件一般也能兼容的。选出股票后能否买入依然还要综合参考大趋势和其它指标。金叉并非万能,有时刚刚进入金叉或准金叉状态,也可能是上一波反弹的结束,下一波下跌的开始。只有当金叉周期的前后周期均为上涨趋势,金叉的威力才最大。

业绩的持续增长才是技术指标的前提和保证。

1、0轴上方第一次金叉选股公式:

DIFF:=EMA(CLOSE,12) – EMA(CLOSE,26);

DEA := EMA(DIFF,9);

MACD := 2*(DIFF-DEA);

xg:cross(diff,dea) and dea>-1.0 and dea<0.5 and CLOSE>ref(CLOSE,1) and CLOSE>=ma(c,60);

或:

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

XG:DIF>0 AND DEA>0 AND CROSS(DIF,DEA);

2、0轴上方二次金叉的选股公式:

JC:IF(SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0)-HHV(IF(IF(CROSS(MACD.DEA,0),1,0),

SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0),0),0)=2 AND SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),

0)>REF(SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0),1),10,0);

{选股设JC=10即可}

3.0轴下方一次金叉的选股公式:

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=(DIFF-DEA)*2;

低位金叉:CROSS(DIFF,DEA) AND DIFF<-0.1;

4、0轴下方二次金叉且第二次金叉高于第一次金叉:

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

AA:=BARSLAST(REF(CROSS(DIF,DEA),1));

二次金叉:CROSS(DIF,DEA) AND DIF>REF(DIF,AA+1) AND AA<20 AND DIF<0;

5、0轴下方二次金叉选股公式:

DIFF:=EMA(CLOSE,12) – EMA(CLOSE,26); {选股设JC=10即可}

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

A:=IF(CROSS(0,DEA),1,0);

A1:=IF(DIFF<0 AND CROSS(DIFF,DEA),1,0);

SS:=IF(A,SUM(A1,0),0);

SSB:=HHV(SS,0);

SSS:=SUM(A1,0);

JC:IF(SSS-SSB=2 AND SSS>REF(SSS,1),10,0);

6、缩量横盘突破选股:

WH01:=(HHV(C,10)-LLV(C,10))/LLV(C,10)*100<=10;

WH02:=SUM(VOL,10)/CAPITAL*100<45;

WH03:=REF(WH01,1);

WH04:=HHVBARS(HIGH,55)>20 OR C=HHV(H,55);

WH05:=WH02 AND WH03 AND WH04 AND C>REF(HHV(H,10),1);

WH05 AND REF(NOT(WH05),1);

7、均线、KDJ、MACD金叉的预警选股公式

完全符合以下条件:

1、5日线上穿10日线

2、MACD金叉

3、KDJ金叉(KDJ数值由9、3、3调整为8、2、2)

4、成交量指标金叉

通达信预警选股公式

A1:=CROSS(MA(C,5),MA(C,10));

A2:=CROSS(MACD.DIF,MACD.DEA);

A3:=CROSS(KDJ.K(8,2,2),KDJ.D(8,2,2));

A4:=CROSS(MA(V,5),MA(V,10));

XG:A1 AND A2 AND A3 AND 4;

三金叉选股完整源码,绝无未来函数

均线、成交量、MACD同时金叉

MA1:=MA(CLOSE,5);

MA2:=MA(CLOSE,10);

AA:=CROSS(MA1,MA2);

AAA:=COUNT(AA,3)>=1;

T1:=MA(VOL,5);

T2:=MA(VOL,10);

BB:=CROSS(T1,T2);

BBB:=COUNT(BB,3)>=1;

DIF:=EMA(CLOSE,12) – EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

CC:=CROSS(DIF,DEA);

CCC:=COUNT(CC,3)>=1;

三金:=AAA AND BBB AND CCC;

三金叉:FILTER(三金,3),COLORFF00FF;

使用说明:该选股公式适合超级短线,快进快出具有一定的风险因素,此时的股价往往处于拉高拔升阶段。

要求使用者特别关注股价所处的位置,如果过于高位防止庄家诱多。低位可大胆搏杀,短期回档被套也有回旋余地。

8、四线粘合

N1:=5;N2:=10;N3:=20;M:=1;

MA1:=MA(C,N1);MA2:=MA(C,N2);MA3:=MA(C,N3);

A3:=V>REF(V,1)*1.5 AND V>MA(V,5);

MAX(MA1,MAX(MA2,MA3))/MIN(MA1,MIN(MA2,MA3))<1+0.01*M

AND C>O AND V> REF(V,1) AND FINANCE(7)<=300000000

AND A3 AND CAPITAL<=300000000;

9、均线粘合

M:=1;

M5:=MA(CLOSE,5);

M10:=MA(CLOSE,10);

M20:=MA(CLOSE,20);

K1:=MAX(MAX(M5,M10),MAX(M10,M20));

K2:=MIN(MIN(M5,M10),MIN(M10,M20));

A:=MAX(M5,MAX(M10,M20))/MIN(M5,MIN(M10,M20))<1+0.01*M;

A1:=(K1/K2-1)<0.005;

A2:=(K1/K2-1)<0.005;

A3:=V>REF(V,1)*1.5 AND V>MA(V,5);

XG:A AND A1 AND A2 AND A3 ;

10、多线粘合

V0:=EMA(C,5);

V1:=EMA(C,10);

V2:=EMA(C,15);

V3:=EMA(C,30);

V4:=EMA(C,60);

M1:=1000*V1/V4<=1015 AND 1000*V1/V4>=975;

M2:=1000*V2/V4<=1020 AND 1000*V2/V4>=980;

M3:=1000*V3/V4<=1015 AND 1000*V3/V4>=985;

M4:=M1 AND M2 AND M3 AND CROSS(V0,V1);

M5:=M1 AND M2 AND M3 AND CROSS(V0,V3);

M4 OR M5;

11、MACD天天挣钱选股指标公式

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

XG:CROSS(REF(DEA,1),REF(DIFF,1)) AND CROSS(DIFF,DEA);

12、短线之王

VAR1:=(-100)*(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3));

CROSS(VAR1,-87) AND OPEN=1.099*REF(CLOSE,1) AND INDEXC>0.98*REF(INDEXC,1) AND CLOSE<=1.47*LLV

(CLOSE,58);

13、自用短线MACD 副图

DIF:EMA(CLOSE,3)-EMA(CLOSE,7);

DEA:EMA(DIF,3);

MACD:(DIF),COLORSTICK;

DIF,COLORGREEN,LINETHICK2;

DEA,COLORGREEN,LINETHICK2;

线上金叉买:0,COLORGREEN,LINETHICK2;

IF(DIF>DEA,DIF,DRAWNULL),COLORRED,LINETHICK2;

IF(DEA>REF(DEA,1),DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;

DRAWICON(CROSS(DIF,DEA),DEA,25);

DRAWICON(CROSS(DEA,DIF),DEA,24);

14 、MACD低位反转点

DIF:EMA(CLOSE,12)-EMA(CLOSE,135);

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

反转:MACD<0 AND MACD>REF(MACD ,1) AND REF(MACD ,1)macd ,2)<="" p="">

AND REF(MACD ,2)

AND REF(MACD ,3)

15.冠军MACD资金流向

DIFF:=EMA(CLOSE,3)-EMA(CLOSE,7);

DEA:=EMA(DIFF,3);

MACD2:=2*(DIFF-DEA);

(CLOSE<0 AND CROSS(DIFF,0),H*1.3),COLOR000080,NODRAW;

(CLOSE<0 AND CROSS(MACD2,0),H*1.3),COLOR000080,NODRAW;

(CLOSE<0 AND CROSS(0,DIFF),H*1.3),COLOR808080,NODRAW;

(CLOSE<0 AND CROSS(0,MACD2),H*1.3),COLOR808080,NODRAW;

DU0:=CROSS(DIFF,0);

UD0:=CROSS(0,DIFF);

TDU0:=BARSLAST(DU0);

TUD0:=BARSLAST(UD0);

DU3:=REF(DU0,1);

UD3:=REF(UD0,1);

TDU3:=BARSLAST(DU3);

TUD3:=BARSLAST(UD3);

UDGLINE:=IF(TDU3

JDU0:=REF(CLOSE,1)<=REF(UDGLINE,1) AND CLOSE>UDGLINE AND TDU0

JUD0:=REF(CLOSE,1)>=REF(UDGLINE,1) AND CLOSE

JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;

JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;

JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)

JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);

JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);

JUD3:=JUD1 AND REF(BARSLAST(JUD1),1)

BSLINE:=IF(BARSLAST(JDU2)

(0,MACD2),1)))),IF(REF(CROSS(MACD2,0),1),HHV(HIGH,2),REF(HHV(HIGH,2),BARSLAST(REF(CROSS(MACD2,0),1)))));

STICKLINE(MACD2>=0,0,MACD2,2,1),COLOR0000FF;

STICKLINE(MACD2>=0 AND MACD2

STICKLINE(MACD2<0,0,MACD2,2,0),COLORFFFF00;

STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,2,1),COLORFFFF00;

DIFIFF,LINETHICK2,COLOR0000FF;

MACDEA,COLORFF0000;

DEF:MACD2,LINETHICK0,COLORFFFF00;

STICKLINE(CLOSE>0,0,0,2,0),COLOR808080;

DEFUT:=BARSLAST(CROSS(MACD2,0));

DEFDT:=BARSLAST(CROSS(0,MACD2));

DEFUL:=IF(MACD2>=0,HHV(MACD2,DEFUT+1),REF(HHV(MACD2,DEFUT+1),DEFDT+1));

DEFDL:=IF(MACD2<0,LLV(MACD2,DEFDT+1),REF(LLV(MACD2,DEFDT+1),DEFUT+1));

DEFU2L:=REF(DEFUL,DEFUT+1);

DEFD2L:=REF(DEFDL,DEFDT+1);

DRAWICON(LLV(MACD2,4)>0 AND MACD2REF(MACD2,2) AND REF(MACD2,2)>REF(MACD2,3),MACD2,2);

DRAWICON(HHV(MACD2,4)<0 AND MACD2>REF(MACD2,1) AND REF(MACD2,1)

DRAWICON((JUD1 OR BARSLAST(JDU1)>BARSLAST(JUD1)) AND MACD2>=0 AND REF(MACD2,1)DEFU2L,MACD2,5);

DRAWICON((JDU1 OR BARSLAST(JDU1)REF(DEFD2L,1) AND MACD2

VAR111:=JDU1 OR BARSLAST(JDU1)

VAR112:=HHV(MACD2,4)<0 AND MACD2>REF(MACD2,1) AND REF(MACD2,1)

16、变色MACD

DIFIF1:=EMA(CLOSE,12) – EMA(CLOSE,26);

DEAEA1:=EMA(DIFIF1,9);

MACD1:=2*(DIFIF1-DEAEA1),STICK;

MACD2:=EMA(MACD1,3);

STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,1,0),COLORRED;

STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,1,0),COLORGREEN;

STICKLINE(MACD1

STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;

DIFIF1,COLOR33FF33,LINETHICK2;

DEAEA1,COLORYELLOW,LINETHICK2;

MACD:MACD1,NODRAW,COLORMAGENTA;

强:IF(DIFIF1>=DEAEA1,DIFIF1,DRAWNULL),COLORRED,LINETHICK2;

弱:IF(DEAEA1>=DIFIF1,DEAEA1,DRAWNULL),COLORFF9900,LINETHICK2;

DRAWICON(CROSS(DIFIF1,DEAEA1),DIFIF1+0.1,1);

DRAWICON(CROSS(DEAEA1,DIFIF1),-0.5,2);

DRAWTEXT(CROSS(DIFIF1,DEAEA1),DIFIF1,’○’),LINETHICK2, COLORYELLOW;

17、至尊MACD{注意用到了未来函数DCLOSE}{本指标只作趋势参考}

DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);

DEA:EMA(DIFF,9),COLORFFFF00;

MACD:(DIFF-DEA)*2;

STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLORRED;

STICKLINE(MACD>=0 AND MACD<=REF(MACD,1),0,MACD,1,0),COLORGREEN;

STICKLINE(MACD<=0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLORFF00FF;

STICKLINE(MACD<=0 AND MACD<=REF(MACD,1),0,MACD,1,0),COLOR00FFFF;

多转空:=((((LLV(MACD,4)>0) AND (MACDREF(MACD,2))) AND (REF(MACD,2)>REF(MACD,3)));

空转多:=((((HHV(MACD,4)<0) AND (MACD>REF(MACD,1))) AND (REF(MACD,1)

DRAWICON(多转空,MACD,2);

DRAWICON(空转多,MACD,1);

低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;

DRAWTEXT(低位金叉,DEA,’ 低位金叉’),COLORFF00FF;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,0.2,2,0),COLORFF00FF;

DRAWTEXT(二次金叉,DEA*1.06,’二次金叉’),COLORRED;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

DRAWTEXT(底背离,-0.2-MACD,’底背离’),COLORWHITE;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,A2+1)DIFF AND CROSS(DEA,DIFF);

DRAWTEXT(顶背离,0.2+MACD,’顶背离’),COLORWHITE;

18、条件选股公式:(双佛手向上) 缺省周期:日线

======================================================================

DIFF := EMA(CLOSE,12) – EMA(CLOSE,26);

DEA := EMA(DIFF,27);

MACD := 2*(DIFF-DEA);

CLOSE>OPEN AND MA(CLOSE,5)>MA(CLOSE,10) and MA(CLOSE,10)>MA(CLOSE,30)

and DIFF>DEA AND MACD>REF(MACD,1) and DIFF>0 AND DEA>0 and MA(VOL,5)>MA(VOL,34)

and MA(CLOSE,30)>=REF(MA(CLOSE,30),1)

=======================================================================================

根据《南征北战之二》中的双佛手向上思路编写,指标用法:

1.DIFF线回调DEA线附近时不死叉,又调头向上。

2.30日均线走平或向上,同时5日线和10日线在30日线上方金叉,且当日收阳线。

3.5日均量线回调到34日均量线附近时不死叉,又调头向上。

以上三个条件要同时成立时将有一波上升浪,应果断买入。

将MACD指标的m参数调为27

19、条件选股公式:(漫步青云) 缺省周期:日线

======================================================================

DIFF := EMA(CLOSE,12) – EMA(CLOSE,26);

DEA := EMA(DIFF,27);

dje:=DIFF>=0 and DEA>=0 and CROSS(DIFF,DEA);

a5:=MA(CLOSE,5)>MA(CLOSE,10);

v5:=VOL>MA(VOL,5) and MA(VOL,5)>MA(VOL,10);

dje and a5 AND V5 AND MA(CLOSE,30)>=REF(MA(CLOSE,30),1)

======================================================

将macd指标的参数调为12,26,27

主要用法:当30日均线走平或上扬,5日均量大于10日均量,当日成交量大于5日均量,

5日均线金叉或已金叉10日均线,macd指标中diff线在0轴上死叉dea线,DIFF线下穿0轴后,又再次上穿并在0轴或0轴上金叉dea线,应果断介入。

但若此时K线离30日,30周,30小时均线较远,不能介入

20、======================================================================

条件选股公式:(空中缆绳) 缺省周期:日线

======================================================================

DIFF := EMA(CLOSE,12) – EMA(CLOSE,26);

DEA := EMA(DIFF,27);

MACD := 2*(DIFF-DEA);

b:=MIN(DIFF,DEA)/MAX(diff,dea)>0.95;

MA(CLOSE,30)>REF(MA(CLOSE,30),1) and diff>0 and dea>0 AND MACD>REF(MACD,1) and b

======================================================================

将MACD指标的参数调为sh:12;long:26;M:27

用法:30日均线上扬或走平,主力开始洗盘。

这时macd指标中的DIFF线随股价的回调而与DEA线在0轴上粘合数值几乎相等,只要5日均线在30日均线上方金叉或已金叉10日均线,macd指标红柱加长,DIFF线脱离DEA线上扬,就是买点。

————

macd五大金叉选股公式

———————————————————

以上公式经过验证有效!

赞(0) 打赏
未经允许不得转载:云搜财经 » macd五大金叉选股公式(MACD和MACD金叉的公式大全)
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

更专业 更方便

联系我们联系我们

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏